Pierścień wokół użytkowników vCenter 2.5 a co za tym idzie VMware Infrastructure z każdą chwilą systematycznie się zaciska. Do połowy grudnia coraz bliżej, a VMware daje nam coraz silniejsze sygnały – „Aktualizujcie się do vSphere 4!”.

Tym razem elementem który ma nas przymusić, aby w dobie kryzysu wyskubać te kilka tysięcy euro na aktualizacje jest SQL 2005 SP2. Pewnie jesteście ciekawi co z nim nie tak, przecież to produkt jakże zażartej konkurencji VMware giganta Microsoft… otóż sprawa jest dosyć prosta. Zgodnie z dokumentem „Cykl wsparcia technicznego produktów firmy Microsoft” jasno napisane jest że oficjalny suport dla SQL  Server 2005 kończy się z dniem 2009-12-15. Czyli akurat w ostatnim dniu umożliwiającym aktualizacje do vSphere4.

Dlaczego ma nas to obchodzić? Według dokumentu: „VMware Virtual Infrastructure Compatibility Matrixes” jedyną wspieraną konfigurację jest SQL Server 2005 Service Pack 2. SP3 nie jest wspierane. Tak więc moi drodzy możemy zostać z środowiskiem produkcyjnym opartym na VI i SQL 2005 SP2 i być zgodnymi z VMware, lub aktualizować się do SP3 i pozbyć się wsparcia, ale mieć poprawki i gwarancję poprawnego działania motora bazy danych. Wybór jest wasz 🙂

Ja mam nadzieje że to co tu przedstawiłem okaże się jedynie teorią spiskową, a VMware nie będzie robić problemów, lub zmieni w swoich dokumentach ten drobny szczegół. Inaczej w ciągu niespełna 10 tygodni czeka nas wszystkich wielka przesiadka na vSphere 4, które w sumie sporo odbiera, a niewiele daje w zamian.

About the author

Bloger i niezależny konsultant z wieloletnim doświadczeniem w branży IT. Specjalizujący się w wirtualizacji i cloud computingu. Posiada tytuły MCP, MCTS, VCP oraz VMware vExpert.

Leave a Reply